My contact forms no longer work in Chrome or Safari. The form will load but errors occur upon clicking “send”. Works still in firefox and Explorer.
———————————————————–
You can temporary modify the file:

your_joomla_root\libraries\joomla\application\application.php

commenting out the new redirect code after the line 323.
The current in that file looks like this:

            if (!$moved && strstr(strtolower($_SERVER['HTTP_USER_AGENT']), 'webkit') !== false) {
                // WebKit browser - Do not use 303, as it causes subresources reload (https://bugs.webkit.org/show_bug.cgi?id=38690)
                echo '<html><head><meta http-equiv="refresh" content="0;'. $url .'" /></head><body></body></html>';
            }
            else {
                // All other browsers, use the more efficient HTTP header method
                header($moved ? 'HTTP/1.1 301 Moved Permanently' : 'HTTP/1.1 303 See other');
                header('Location: '.$url);
            }

Replace it with :

//            if (!$moved && strstr(strtolower($_SERVER['HTTP_USER_AGENT']), 'webkit') !== false) {
                // WebKit browser - Do not use 303, as it causes subresources reload (https://bugs.webkit.org/show_bug.cgi?id=38690)
//                echo '<html><head><meta http-equiv="refresh" content="0;'. $url .'" /></head><body></body></html>';
//            }
//            else {
                // All other browsers, use the more efficient HTTP header method
                header($moved ? 'HTTP/1.1 301 Moved Permanently' : 'HTTP/1.1 303 See other');
                header('Location: '.$url);
//            }

After the new version of aiContactSafe is released and installed you will just have to remove those slashes.

Source: http://www.jvitals.com/support/forum-support/topic?id=987#p5046

Pin It on Pinterest

Share This